1151 Easy Fibonacci

SemiColon
By -
1 minute read
0
URI Online Judge | 1151

Easy Fibonacci

The following sequence of numbers 0 1 1 2 3 5 8 13 21 ... is known as the Fibonacci Sequence. Thereafter, each number after the first 2 is equal to the sum of the previous two numbers. Write an algorithm that reads an integer N (N < 46) and that print the first N numbers of this sequence.

Input

The input file contains an integer number N (0 < N < 46).

Output

The numbers ​​should be printed on the same line, separated by a blank space. There is no space after the last number.
Input SampleOutput Sample
50 1 1 2 3


Solution:
#include <stdio.h>
int main()
{
    int i, n, t1 = 0, t2 = 1,temp;
    scanf("%d", &n);
    if(n==0)
    {
        printf("0\n");
    }
    else
    {
    printf("0");
    for (i = 2; i <= n; i++)
    {
        temp = t1 + t2;
        t1 = t2;
        t2 = temp;
        printf(" %d", t1);
    }
    }
    printf("\n");


    return 0;
}



Tags:

Post a Comment

0Comments

Post a Comment (0)